In order to run Alexandria Book Library you need all the recommended requirement that you find in Joomla official site.
These are:

 

Windows or Linux (Linux is better, it's free, open source, without virus, much fast and cool! ;-) )
Apache 2.X
PHP 5.X
MySQL 4.X
Joomla 1.5 (soon also 1.6)

These are versions in which we tested Alexandria Book Library. You can try to install it on different versions and if it goes up, well!! Please refer us and we tell it to the world, thanks!